EXPO HELP FAQ

Frequently Asked Questions for Error Messages

 Please click on “forgot your username and password” in login page or go to https://expo.uw.edu/expo/session/forgot. Expo will send you the reminders after your request.

 

 This is usually because your browser does not have the UW service certificate. Install it from here: https://www.washington.edu/itconnect/security/ca/. It will not show up anymore after you installed it. 

 
Also, it will be helpful to double check your link/URL is with Hypertext Transfer Protocol Secure (HTTPS). 
 

 

You might be logged in with a wrong link and accessed EXPO without a student role.

To solve the issue, please follow the steps below:

  1. Close your entire browser (not just tabs) or open Google Chrome Incognito window or Firefox private window.
  2. Enter the correct link such as expo.uw.edu/apply for your online applications.
  3. Click on “Sign in” and login with your UW NetID.

 

To check if you logged as a student, you can check the information on the top right corner in EXPO. It should display like this:

If you don’t see [Student], you might be logged as a UW standard user accidently. 

To make sure logging as a student, please follow the steps below:

  1. Close your entire browser (not just tabs) or open Google Chrome Incognito window or Firefox private window.
  2. Enter the correct link such as expo.uw.edu/apply for your online applications.
  3. Click on “Sign in” and login with your UW NetID.

You might have been logged in without a login or invite link that should map with your user record. Please reach out the admin staff who contact you to help solve this situation. 

Thank you for your patience.